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Autocad Model Space and Paper Space 
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• Create Irregularly Shaped Viewports 
• Freeze and Thaw Layers for Each Viewport 
• Plotting Drawings From Layout Tab View 

 
 
Model Space vs. Paper Space 
 
From the Autocad® Help Files: 

There are two distinct working environments, or “spaces,” in which you can create objects in a drawing.  

Typically, a model composed of geometric objects is created in a three-dimensional space called model space. A final layout 
of specific views and annotations of this model is created in a two-dimensional space called paper space. These spaces are 
accessible on two or more tabs near the bottom of the drawing area: the Model tab and one or more layout tabs. 

Note These tabs can be hidden, appearing instead as buttons on the status bar at the bottom-center of the application window. 

Working on the Model tab, you draw a model of your subject at 1:1 scale. Working on a layout tab, you place one or more 
viewports, dimensions, notes, and a title block to represent a drawing sheet. 

On a layout tab, each layout viewport is like a picture frame containing a “photograph” of the model. Each layout viewport 
contains a view that displays the model at the scale and orientation that you specify. You can also specify which layers are 
visible in each layout viewport. 

After you finish arranging the layout, you turn off the layer that contains the layout viewport objects. The views are still 
visible, and you can plot the layout without displaying the viewport boundaries. 

Notes 
 

• As stated above, you can create viewport objects on a specific layer and then turn that layer OFF to keep the 
frame from plotting. However, newer versions of Autocad® allow layers to be designated as “No Plot” layers to 
achieve the same goal. 

 
• The default screen color background for Model Space is Black. The default screen color background for Paper 

Space is White (simulating a sheet of paper). This is your best indicator of what space you are working in.  
 

 
Continued on Next Page 
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Model Space vs. Paper Space (Continued) 
 
• Additionally, the UCS Icon in the bottom left corner of the drawing area or viewport indicates the current 

space and orientation. If the Icon is not visible, type the command UCSICON at the command line and turn it 
ON. 

 
  

UCS Icon in Model Space UCS Icon in Paper Space 

 
• The third way to confirm which space you are currently working in is the Status Bar at the bottom of the 

Autocad screen. 
 
 
 
 
Initial Setup 
 
When first working with Paper Space and viewports, setting the Display Options shown below seems to reduce 
confusion and does not take away any of the functionality of Layouts. 

 
1. Right click in the command line and select Options. 
2. Go to the Display tab and UNcheck everything except for “Display Layout and Model tabs” in the “Layout 

Elements” section of the box. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Then select the “Colors” button in the “Window Elements” section of the box to open the “Drawing Window 
Colors” dialog box. 

 
Continued on Next Page 
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Initial Setup (Continued) 
 

4. In the “Context” list, select “Sheet/Layout” and then select “Black” from the “Color” list.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note: Setting the color of the Sheet/Layout background to Black is completely optional. If you typically work with a 
black background in Model Space, it will probably be more comfortable for you to also set the Sheet/Layout 
background to Black. However, keeping the Sheet/Layout background White does present another visual indicator that 
you are working in Paper Space. 
 
 
Create and Set Up Layout Tab for Plotting 
 

1. Left click on one of the “Layout” tabs at the bottom of the drawing screen to make it current.  
2. Rename the Layout by right-clicking on the tab and selecting “Rename” command and typing in the new name. 
3. Insert your standard title block into the Layout drawing area by using the standard INSERT> BLOCK command.  
 

Note: While in Paper Space, one unit represents the distance on a sheet of paper. For English units, these 
measurements will be in Inches. For instance, a 24”x36” title block will measure exactly 24 units x 36 units in 
layout view/paper space – regardless of the plotted scale of the drawing. 
 

4. Create a new layer for your viewport. This layer should be reserved for viewport entities as this layer will 
either be turned OFF or set to No Plot. If using the National CAD Standard, the layer G-NPLT is meant for non-
plotting layers. 

5. Set this layer current. 
 
 
Create Viewports 
 

1. Create a new viewport by issuing the MVIEW command with the Fit option. This is most easily done by typing in 
“MV” at the command line. The default option (Fit) prompts you to pick two opposite corners of the viewport 
window.  

2. When the viewport is opened, the view of Model Space is Zoomed to the Extents. If you don’t see anything in 
the viewport it could be that you have stray entities in your Model Space so that, when Zoomed to Extents, 
everything is very small and at the edges of the drawing area. 

 
Note: You can create an unlimited number of viewports in any drawing or Layout tab – but only 64 viewports can be 
Active at one time per layout. Model Space entities are visible only through Active viewports. Viewports are Active 
if they are turned ON through the Object Properties task pane or by using the MVIEW command.  

 
 



TCG_ModelSpaceAndPaperSpace_Method.doc 
© 2007 Jennifer L. DiBona 

Page 4 of 7 

 

Frame and Scale the Model Space View Through the Viewport 
 

1. Left click on the Layout tab you wish to make current. 
2. Double click inside the viewport to make it current. Once you’ve done this, you should see “MODEL” on the 

status bar indicating that you are working in Model Space. Because your “Layout” tab is still current, you are 
now working “in Model Space through Paper Space”. 

 
 
 
 

 
Note 
 
While working in Model Space through Paper Space, you will also notice: 

a. The viewport frame has become bold, 
b. You have crosshairs inside the viewport, but not outside, 
c. You can not select the viewport frame and 
d. You can not work on areas outside the viewport – for instance, inside a command, your left mouse and 

any Zoom or Pan functions only work inside the viewport. 
 

3. Use your Zoom and Pan commands or your mouse scroll wheel to center and frame out the area of Model Space 
you wish to be the focal point of this drawing. The final plot scale of the drawing does not matter at this time. 

4. Set the viewport scale by: 
a. Double-clicking outside the viewport to set paper space current 
b. Left click ONCE on the viewport frame to select the viewport object and then right-click and select 

Properties from the shortcut menu to open the Properties task pane 
c. In the Properties task pane, under the Misc heading, select the drop-down next to “Standard Scale” 

and select the desired scale for the viewport. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Continued on Next Page 
 



TCG_ModelSpaceAndPaperSpace_Method.doc 
© 2007 Jennifer L. DiBona 

Page 5 of 7 

 

Frame and Scale the Model Space View Through the Viewport (Continued) 
 

5. If the view is framed as desired, left click once on the viewport frame to select the viewport entity and then 
right click, pick “Display Locked” from the shortcut menu and select “Yes”. This will keep you from 
accidentally changing the scale of the drawing in the viewport. The “Display Locked” setting can also be 
changed in the Properties task pane. 

6. Once created, viewports can be moved, copied, scaled and grip-edited to change the viewport size or location. 
 
Note: The DVIEW or UCS commands can be used to change the view orientation of each viewport. The viewport 
“Display Locked” property must be turned OFF before this can be changed. 

 
 
Create Irregularly Shaped Viewports 
 
By default, the MVIEW command creates a rectangular-shaped viewport. While a viewport can not have a shape other 
than a rectangle, Autocad® allows us to mask the viewport using with polylines, circles or other shapes to give the 
impression of an irregularly shaped viewport. 
 
There are two ways to create an irregularly shaped viewport. 
 

1. Create a rectangle shaped viewport using the MVIEW> Fit method outlined in a previous section. 
2. Draw a circle or closed polyline on top of the viewport outlining the area to be visible. 
3. Type VPCLIP at the command line and follow the prompts. 

 
Or 
 
1. Use the MVIEW command with the Polygonal option. 
2. Select the vertices of a polygon outlining the area to create a viewport. 

 
Using either method results in having two entities creating the viewport: 1 viewport entity and 1 polyline or circle 
masking the unwanted areas of the viewport. Although it’s only one entity, selecting a polyline or circle that is masking 
the viewport and opening the Properties task pane shows this: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
To access the viewport properties such as “Standard Scale” and “Display Locked”, you must first select the viewport 
entity from the Properties drop-down. 
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Freeze and Thaw Layers for Each Viewport 
 

From the Layer pull-down bar: 
 
 
 
 
 
 
 
 
 
 
• The first two columns of icons next to each layer name will affect visibility of the layer in Model Space and ALL 

viewports. 
• The third column controls layers several different ways depending on the tab and space you are working in. 

o When working in the Model tab, this column is not accessible at all. 
o When working in a Layout tab in Paper Space, this column of icons controls visibility of entities drawn 

in paper space. 
o When working inside a Model Space viewport while in a Layout tab, this column of icons controls 

visibility of Model Space entities in the current viewport. 
 
To freeze and thaw layers for each viewport: 

1. Double-click in side a viewport to set it current. 
2. Freezing or Thawing layers in a viewport can be done several different ways, 

a. Using the layer pull-down box (shown above), left-click on the 3rd column of icons to show a sun      to 
make a layer visible (Thaw) or to show a snowflake         to make it invisible (Freeze). 

 
b. Use the Express Tools> Layers> Freeze toolbar icon in pre-2007 Autocad®. 
  
 
 
c. Use the Freeze toolbar icon from the Layers II toolbar in 2007+ Autocad®. 

 
 
 
3. When you are finished freezing and thawing layers in the viewport, double-click outside the viewport to set 

paper space current. 
 
 
Create Additional Layout Views/Tabs 
 
Once a layout tab has been set up for your project, you may wish to make additional copies of the layout tab and its 
set up. For instance, if you create a layout tab for plotting a Site Plan, you might make a copy of the layout to be used 
as a Grading Plan since the only difference is the layers visible in each. 
 

1. Right-click on the layout tab that you want to use to create additional layouts and select “Move or Copy”. 
2. In the list of layouts, select the layout you want the new copy to be sorted IN FRONT OF. 
3. Place a check in the box next to “Create Copy” and pick OK. 
4. The new layout will be named the same as the original but will have a “(2)” behind it. 
5. If the original layout contained viewports, the new copied layout will contain copies of the viewports. 

However, the new copied viewport will be turned OFF (Inactive). Left click once on the viewport frame to 
select the viewport, right-click and pick “Display Viewport Objects” and set to “Yes” to make the viewport 
Active. 
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Plotting the drawings from Layout view 
 

1. Left click and set current the Layout tab you wish to plot. 
2. Make sure the Status Bar at the bottom of the Autocad window indicates that you are in PAPER space. 

 
 
 
 

3. When plotting drawings that are set up through with paper space, the plot scale will be 1:1 because the scale 
factor is being applied through the viewport setup instead of through the plotting process. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Use typical values for remaining plot settings. 


